En bref
- CVE-2017-18214 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant moment (momentjs), nessus (tenable), moment.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.6%, plus élevée que 89.6% des vulnérabilités.
- Correctif : mettre à jour vers 2.19.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| moment | ≤ 2.19.2
| No fix yet |
| nessus | ≤ 8.2.3
| No fix yet |
| moment npm | < 2.19.3
| 2.19.3
|
Description
Affected versions of moment are vulnerable to a low severity regular expression denial of service when parsing dates as strings.
Recommendation
Update to version 2.19.3 or later.
NVD description
The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free