En bref
- CVE-2017-20162 est une vulnérabilité MOYENNE (CVSS 5.3) touchant ms (vercel), ms.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.0%, plus élevée que 63.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| ms | < 2.0.0
| 2.0.0
|
| ms npm | < 2.0.0
| 2.0.0
|
Description
A vulnerability, which was classified as problematic, has been found in vercel ms up to 1.x. This issue affects the function parse of the file index.js. The manipulation of the argument str leads to inefficient regular expression complexity. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The name of the patch is caae2988ba2a37765d055c4eee63d383320ee662. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217451.
NVD description
A vulnerability, which was classified as problematic, has been found in vercel ms up to 1.x. This issue affects the function parse of the file index.js. The manipulation of the argument str leads to inefficient regular expression complexity. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named caae2988ba2a37765d055c4eee63d383320ee662. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217451.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free