En bref
- CVE-2018-1000078 est une vulnérabilité MOYENNE (CVSS 6.1) touchant org.jruby:jruby-stdlib, rubygems-update, rubygems (rubygems).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.7%, plus élevée que 86.2% des vulnérabilités.
- Correctif : mettre à jour vers 9.1.16.0, 2.7.6 ou plus récent.
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack requires the victim to browse to a malicious gem on a vulnerable gem server. This vulnerability is fixed in 2.7.6.
NVD description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.
Autres vulnérabilités de org.jruby:jruby-stdlib
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free