En bref
- CVE-2018-1000164 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant gunicorn, gunicorn (gunicorn).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.4%, plus élevée que 83.9% des vulnérabilités.
- Correctif : mettre à jour vers 19.5.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| gunicorn PyPI | < 19.5.0
| 19.5.0
|
| gunicorn | = 19.4.5
| No fix yet |
Description
gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.
NVD description
gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free