En bref
- CVE-2018-1000807 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant pyopenssl, pyopenssl (pyopenssl), openstack (redhat).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 4.1%, plus élevée que 90.7% des vulnérabilités.
- Correctif : mettre à jour vers 17.5.0 ou plus récent.
Description
It was discovered that pyOpenSSL incorrectly handled memory when handling X509 objects. A remote attacker could use this issue to cause pyOpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code. This attack appears to be exploitable via Depends on the calling application and if it retains a reference to the memory. This vulnerability appears to have been fixed in 17.5.0.
NVD description
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free