En bref
- CVE-2018-1002203 est une vulnérabilité MOYENNE (CVSS 5.5) touchant unzipper (unzipper project), unzipper.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 10.6%, plus élevée que 95.8% des vulnérabilités.
- Correctif : mettre à jour vers 0.8.13 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| unzipper | < 0.8.13
| 0.8.13
|
| unzipper npm | < 0.8.13
| 0.8.13
|
Description
Versions of unzipper before 0.8.13 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.3.18 or later.
NVD description
unzipper npm library before 0.8.13 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free