En bref
- CVE-2018-1002204 est une vulnérabilité MOYENNE (CVSS 5.5) touchant adm-zip (adm-zip project), adm-zip.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 13.5%, plus élevée que 96.4% des vulnérabilités.
- Correctif : mettre à jour vers 0.4.9, 0.4.11 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| adm-zip | < 0.4.9
| 0.4.9
|
| adm-zip npm | < 0.4.11
| 0.4.11
|
Description
Versions of adm-zip before 0.4.9 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.4.9 or later.
NVD description
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free