En bref
- CVE-2018-1109 est une vulnérabilité MOYENNE (CVSS 5.3) touchant braces (braces project), braces.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 72.4% des vulnérabilités.
- Correctif : mettre à jour vers 2.3.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| braces | < 2.3.1
| 2.3.1
|
| braces npm | ≥ 2.2.0, < 2.3.1
| 2.3.1
|
Description
A vulnerability was found in Braces versions from v2.2.0 up to but not including v2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks. This has been patched in version 2.3.1.
NVD description
A vulnerability was found in Braces versions 2.2.0 and above, prior to 2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free