En bref
- CVE-2018-16493 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant static-resource-server (static-resource-server project), static-resource-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.8%, plus élevée que 78.2% des vulnérabilités.
- Aucune version corrigée n'est encore connue : suivez l'avis de l'éditeur dans les références.
Description
Versions of simplehttpserver prior to 0.2.1 are vulnerable to Path Traversal. Due to insufficient input sanitization, attackers can access server files by using relative paths.
Recommendation
Upgrade to version 0.2.1 or later.
NVD description
A path traversal vulnerability was found in module static-resource-server 1.7.2 that allows unauthorized read access to any file on the server by appending slashes in the URL.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free