En bref
- CVE-2018-17196 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant org.apache.kafka:kafka, kafka (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 5.4%, plus élevée que 92.7% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.1 ou plus récent.
Description
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.
NVD description
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.
Autres vulnérabilités de org.apache.kafka:kafka
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free