En bref
- CVE-2018-25031 est une vulnérabilité MOYENNE (CVSS 4.3) touchant org.webjars:swagger-ui, swagger ui (smartbear), swagger-ui.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 42.3%, plus élevée que 98.7% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.3 ou plus récent.
Description
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
NVD description
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Autres vulnérabilités de org.webjars:swagger-ui
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free