En bref
- CVE-2018-25079 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant is-url (segment), is-url.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.95%, plus élevée que 61.5% des vulnérabilités.
- Correctif : mettre à jour vers 1.2.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| is-url | ≤ 1.2.2
| No fix yet |
| is-url npm | < 1.2.3
| 1.2.3
|
Description
A vulnerability was found in Segmentio is-url up to 1.2.2. It has been rated as problematic. Affected by this issue is an unknown functionality of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. Upgrading to version 1.2.3 is able to address this issue. The name of the patch is 149550935c63a98c11f27f694a7c4a9479e53794. It is recommended to upgrade the affected component. VDB-220058 is the identifier assigned to this vulnerability.
NVD description
A vulnerability was found in Segmentio is-url up to 1.2.2. It has been rated as problematic. Affected by this issue is some unknown functionality of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. Upgrading to version 1.2.3 is able to address this issue. The patch is identified as 149550935c63a98c11f27f694a7c4a9479e53794. It is recommended to upgrade the affected component. VDB-220058 is the identifier assigned to this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free