En bref
- CVE-2018-3715 est une vulnérabilité MOYENNE (CVSS 6.5) touchant glance (glance project), glance.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.5%, plus élevée que 73.6% des vulnérabilités.
- Correctif : mettre à jour vers 3.0.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.4
| 3.0.4
|
| glance npm | < 3.0.4
| 3.0.4
|
Description
Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Recommendation
Update to version 3.0.4 or later.
NVD description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free