En bref
- CVE-2018-3720 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant assign-deep (assign-deep project), assign-deep.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.0%, plus élevée que 80.7% des vulnérabilités.
- Correctif : mettre à jour vers 0.4.7 ou plus récent.
Description
Versions of assign-deep before 0.4.7 are vulnerable to prototype pollution via merging functions.
Recommendation
Update to version 0.4.7 or later.
NVD description
assign-deep node module before 0.4.7 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free