En bref
- CVE-2018-3723 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant defaults-deep (defaults-deep project), defaults-deep.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.0%, plus élevée que 80.9% des vulnérabilités.
- Correctif : mettre à jour vers 0.2.4 ou plus récent.
Description
Versions of default-deep before 0.2.4 are vulnerable to prototype pollution
Recommendation
Update to version 0.2.4 or later.
NVD description
defaults-deep node module before 0.2.4 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free