En bref
- CVE-2018-3725 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant hekto (hekto project), hekto.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.0%, plus élevée que 80.9% des vulnérabilités.
- Correctif : mettre à jour vers 0.2.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| hekto | = 0.2.0
| No fix yet |
| hekto npm | < 0.2.3
| 0.2.3
|
Description
Versions of hekto before 0.2.3 are vulnerable to path traversal. This allows a remote attacker to read content of arbitrary files.
Recommendation
Update to version 0.2.3 or later.
NVD description
hekto node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free