En bref
- CVE-2018-3745 est une vulnérabilité CRITIQUE (CVSS 9.1) touchant atob (atob project), atob.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.1%, plus élevée que 82.1% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| atob | ≤ 2.0.3
| No fix yet |
| atob npm | < 2.1.0
| 2.1.0
|
Description
Versions of atob before 2.1.0 uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Recommendation
Update to version 2.1.0 or later.
NVD description
atob 2.0.3 and earlier allocates uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free