En bref
- CVE-2018-3750 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant deep extend (deep extend project), deep-extend.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.1%, plus élevée que 82.2% des vulnérabilités.
- Correctif : mettre à jour vers 0.5.1 ou plus récent.
Description
Versions of deep-extend before 0.5.1 are vulnerable to prototype pollution.
Recommendation
Update to version 0.5.1 or later.
NVD description
The utilities function in all versions <= 0.5.0 of the deep-extend node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free