En bref
- CVE-2018-3752 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant merge-options (merge-options project), merge-options.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 73.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.0.1 ou plus récent.
Description
All versions of merge-options are vulnerable to Prototype Pollution
Recommendation
Update to version 1.0.1 or greater.
NVD description
The utilities function in all versions <= 1.0.0 of the merge-options node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free