En bref
- CVE-2018-3767 est une vulnérabilité CRITIQUE (CVSS 9.1) touchant memjs (memcachier), memjs.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.5%, plus élevée que 73.6% des vulnérabilités.
- Aucune version corrigée n'est encore connue : suivez l'avis de l'éditeur dans les références.
| Package | Affected versions | Patched versions |
|---|
| memjs | ≤ 1.1.0
| No fix yet |
| memjs npm | ≤ 1.2.0
| No fix yet |
Description
Versions of memjs prior to 1.2.2 are vulnerable to Denial of Service (DoS). The package fails to sanitize the value option passed to the Buffer constructor, which may allow attackers to pass large values exhausting system resources.
Recommendation
Upgrade to version 1.2.2 or later.
NVD description
`memjs` versions <= 1.1.0 allocates and stores buffers on typed input, resulting in DoS and uninitialized memory usage.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free