En bref
- CVE-2018-3774 est une vulnérabilité CRITIQUE (CVSS 10.0) touchant url-parse.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.8%, plus élevée que 90.0% des vulnérabilités.
- Correctif : mettre à jour vers 1.4.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| url-parse npm | ≥ 1.0.0, < 1.4.3
| 1.4.3
|
Description
Versions of url-parse before 1.4.3 returns the wrong hostname which could lead to Open Redirect, Server Side Request Forgery (SSRF), or Bypass Authentication Protocol vulnerabilities.
Recommendation
Update to version 1.4.3 or later.
NVD description
Incorrect parsing in url-parse <1.4.3 returns wrong hostname which leads to multiple vulnerabilities such as SSRF, Open Redirect, Bypass Authentication Protocol.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free