En bref
- CVE-2018-3778 est une vulnérabilité MOYENNE (CVSS 5.3) touchant aedes (aedes project), aedes.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 72.9% des vulnérabilités.
- Correctif : mettre à jour vers 0.35.0, 0.35.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| aedes | < 0.35.0
| 0.35.0
|
| aedes npm | < 0.35.1
| 0.35.1
|
Description
Versions of aedes before 0.35.1 does not respect its own authorization rules when a client sets a Last Will.
Recommendation
Update to version 0.35.1 or later.
NVD description
Improper authorization in aedes version <0.35.0 will publish a LWT in a channel when a client is not authorized.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free