En bref
- CVE-2018-7651 est une vulnérabilité MOYENNE (CVSS 5.9) touchant ssri (ssri project), ssri.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 77.4% des vulnérabilités.
- Correctif : mettre à jour vers 5.2.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| ssri | < 5.2.2
| 5.2.2
|
| ssri npm | < 5.2.2
| 5.2.2
|
Description
Version of ssri prior to 5.2.2 are vulnerable to regular expression denial of service (ReDoS) when using strict mode.
Recommendation
Update to version 5.2.2 or later.
NVD description
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free