En bref
- CVE-2019-0187 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.jmeter:ApacheJMeter, jmeter (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.6%, plus élevée que 85.6% des vulnérabilités.
- Correctif : mettre à jour vers 5.1 ou plus récent.
Description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
NVD description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
Autres vulnérabilités de org.apache.jmeter:ApacheJMeter
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free