En bref
- CVE-2019-1000011 est une vulnérabilité MOYENNE (CVSS 6.5) touchant api-platform/core, core (api-platform).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.0%, plus élevée que 63.7% des vulnérabilités.
- Correctif : mettre à jour vers 2.2.10, 2.3.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| api-platform/core Packagist | ≥ 2.2.0, < 2.2.10≥ 2.3.0, < 2.3.6
| 2.2.102.3.6
|
| core | ≥ 2.2.0, ≤ 2.3.5
| No fix yet |
Description
API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.
NVD description
API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free