En bref
- CVE-2019-15608 est une vulnérabilité MOYENNE (CVSS 5.9) touchant yarn (yarnpkg), yarn.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.8%, plus élevée que 79.0% des vulnérabilités.
- Correctif : mettre à jour vers 1.19.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| yarn | < 1.19.0
| 1.19.0
|
| yarn npm | < 1.19.0
| 1.19.0
|
Description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack. This issue is fixed in 1.19.0.
NVD description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free