En bref
- CVE-2019-16097 est une vulnérabilité MOYENNE (CVSS 6.5) touchant github.com/goharbor/harbor, harbor (linuxfoundation).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 22.4%, plus élevée que 97.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.9.0-rc1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/goharbor/harbor Go | ≥ 1.7.0, < 1.9.0-rc1
| 1.9.0-rc1
|
| harbor | = 1.7.0= 1.7.1= 1.7.2= 1.7.3= 1.7.4= 1.7.5= 1.8.0= 1.8.1= 1.8.2= 1.9.0
| No fix yet |
Description
core/api/user.go in Harbor 1.7.0 through 1.8.2 allows non-admin users to create admin accounts via the POST /api/users API. This is fixed in 1.9.0-rc1.
NVD description
core/api/user.go in Harbor 1.7.0 through 1.8.2 allows non-admin users to create admin accounts via the POST /api/users API, when Harbor is setup with DB as authentication backend and allow user to do self-registration. Fixed version: v1.7.6 v1.8.3. v.1.9.0. Workaround without applying the fix: configure Harbor to use non-DB authentication backend such as LDAP.
Autres vulnérabilités de github.com/goharbor/harbor
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free