En bref
- CVE-2019-16763 est une vulnérabilité MOYENNE (CVSS 6.1) touchant pannellum (pannellum), pannellum.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.70%, plus élevée que 53.2% des vulnérabilités.
- Correctif : mettre à jour vers 2.5.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pannellum | ≥ 2.5.0, ≤ 2.5.4
| No fix yet |
| pannellum npm | ≥ 2.5.0, < 2.5.5
| 2.5.5
|
Description
Versions of pannellum prior to 2.5.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize URLs for data URIs, which may allow attackers to execute arbitrary code in a victim's browser.
Recommendation
Upgrade to version 2.5.6 or later.
NVD description
In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an <iframe> could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free