En bref
- CVE-2019-19588 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant validators, validators (validators project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.5%, plus élevée que 73.8% des vulnérabilités.
- Correctif : mettre à jour vers 0.12.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| validators PyPI | ≥ 0.12.2, < 0.12.6
| 0.12.6
|
| validators | ≥ 0.12.2, ≤ 0.12.5
| No fix yet |
Description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
NVD description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free