En bref
- CVE-2019-5413 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant morgan (morgan project), morgan.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.4%, plus élevée que 88.9% des vulnérabilités.
- Correctif : mettre à jour vers 1.9.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| morgan | < 1.9.1
| 1.9.1
|
| morgan npm | < 1.9.1
| 1.9.1
|
Description
Verisons of morgan before 1.9.1 are vulnerable to code injection when user input is allowed into the filter or combined with a prototype pollution attack.
Recommendation
Update to version 1.9.1 or later.
NVD description
An attacker can use the format parameter to inject arbitrary commands in the npm package morgan < 1.9.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free