En bref
- CVE-2019-5415 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant serve (zeit), serve.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 76.4% des vulnérabilités.
- Correctif : mettre à jour vers 7.0.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| serve | = 6.5.3
| No fix yet |
| serve npm | < 7.0.0
| 7.0.0
|
Description
Versions of serve prior to 7.0.1 are vulnerable to Path Traversal. Explicitly ignored folders can be accessed through if the path contains a /./, which allows attackers to access hidden folders and files.
Recommendation
Upgrade to version 7.0.1 or later.
NVD description
A bug in handling the ignore files and directories feature in serve 6.5.3 allows an attacker to read a file or list the directory that the victim has not allowed access to.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free