En bref
- CVE-2019-5484 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant bower (bower), bower.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.6%, plus élevée que 85.2% des vulnérabilités.
- Correctif : mettre à jour vers 1.8.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| bower | < 1.8.8
| 1.8.8
|
| bower npm | < 1.8.8
| 1.8.8
|
Description
Versions of bower prior to 1.8.8 are affected by an arbitrary file write vulnerability. The vulnerability occurs because bower does not verify that extracted symbolic links do not resolve to targets outside of the extraction root directory.
Recommendation
Update to version 1.8.8 or later
NVD description
Bower before 1.8.8 has a path traversal vulnerability permitting file write in arbitrary locations via install command, which allows attackers to write arbitrary files when a malicious package is extracted.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free