En bref
- CVE-2019-8321 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant rubygems-update, rubygems (rubygems).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.3%, plus élevée que 88.4% des vulnérabilités.
- Correctif : mettre à jour vers 2.7.9, 3.0.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.6.0, < 2.7.9≥ 3.0.0, < 3.0.2
| 2.7.93.0.2
|
| rubygems | ≥ 2.6.0, ≤ 3.0.2
| No fix yet |
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.
NVD description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free