En bref
- CVE-2020-11052 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant sorcery, sorcery (sorcery project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 75.9% des vulnérabilités.
- Correctif : mettre à jour vers 0.15.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| sorcery RubyGems | < 0.15.0
| 0.15.0
|
| sorcery | < 0.15.0
| 0.15.0
|
Description
Impact
Brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout.
Patches
Patched as of version 0.15.0.
Workarounds
Currently no workarounds, other than monkey patching the authenticate method provided by Sorcery or upgrading to version 0.15.0.
NVD description
In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free