En bref
- CVE-2020-15174 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant electron (electronjs), electron.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 71.4% des vulnérabilités.
- Correctif : mettre à jour vers 10.0.1, 8.5.1, 9.3.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| electron | ≥ 10.0.0, < 10.0.1≥ 8.0.0, < 8.5.1≥ 9.0.0, < 9.3.0
| 10.0.18.5.19.3.0
|
| electron npm | ≥ 10.0.0-beta.0, < 10.0.1≥ 8.0.0-beta.0, < 8.5.1≥ 9.0.0-beta.0, < 9.3.0
| 10.0.18.5.19.3.0
|
Description
Impact
The will-navigate event that apps use to prevent navigations to unexpected destinations as per our security recommendations can be bypassed when a sub-frame performs a top-frame navigation across sites.
Patches
11.0.0-beta.1
10.0.1
9.3.0
8.5.1
Workarounds
Sandbox all your iframes using the sandbox attribute. This will prevent them creating top-frame navigations and is good practice anyway.
For more information
If you have any questions or comments about this advisory:
NVD description
In Electron before versions 11.0.0-beta.1, 10.0.1, 9.3.0 or 8.5.1 the `will-navigate` event that apps use to prevent navigations to unexpected destinations as per our security recommendations can be bypassed when a sub-frame performs a top-frame navigation across sites. The issue is patched in versions 11.0.0-beta.1, 10.0.1, 9.3.0 or 8.5.1 As a workaround sandbox all your iframes using the sandbox attribute. This will prevent them creating top-frame navigations and is good practice anyway.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free