En bref
- CVE-2020-26213 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant ktbs.dev/teler, teler (teler project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 73.1% des vulnérabilités.
- Correctif : mettre à jour vers 0.0.1 ou plus récent.
Description
Impact
If you run teler inside a Docker container and encounter errors.Exit function, it will cause denial-of-service (SIGSEGV) because it doesn't get process ID and process group ID of teler properly to kills.
Specific Go Packages Affected
ktbs.dev/teler/pkg/errors
Patches
Upgrade to the >= 0.0.1 version.
Workarounds
N/A
References
For more information
If you have any questions or comments about this advisory:
NVD description
In teler before version 0.0.1, if you run teler inside a Docker container and encounter `errors.Exit` function, it will cause denial-of-service (`SIGSEGV`) because it doesn't get process ID and process group ID of teler properly to kills. The issue is patched in teler 0.0.1 and 0.0.1-dev5.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free