En bref
- CVE-2020-4077 est une vulnérabilité CRITIQUE (CVSS 9.9) touchant electron (electronjs), electron.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.0%, plus élevée que 63.0% des vulnérabilités.
- Correctif : mettre à jour vers 7.2.4, 8.2.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| electron | = 9.0.0≥ 7.0.0, < 7.2.4≥ 8.0.0, < 8.2.4
| 7.2.48.2.4
|
| electron npm | ≥ 8.0.0, < 8.2.4< 7.2.4
| 8.2.47.2.4
|
Description
Impact
Apps using both contextIsolation and contextBridge are affected.
This is a context isolation bypass, meaning that code running in the main world context in the renderer can reach into the isolated Electron context and perform privileged actions.
Workarounds
There are no app-side workarounds, you must update your Electron version to be protected.
Fixed Versions
9.0.0-beta.21
8.2.4
7.2.4
For more information
If you have any questions or comments about this advisory:
NVD description
In Electron before versions 7.2.4, 8.2.4, and 9.0.0-beta21, there is a context isolation bypass. Code running in the main world context in the renderer can reach into the isolated Electron context and perform privileged actions. Apps using both `contextIsolation` and `contextBridge` are affected. This is fixed in versions 9.0.0-beta.21, 8.2.4 and 7.2.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free