En bref
- CVE-2020-7618 est une vulnérabilité MOYENNE (CVSS 5.3) touchant sds (sds project), sds.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.1%, plus élevée que 66.9% des vulnérabilités.
- Correctif : mettre à jour vers 4.0.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| sds | ≤ 3.2.0
| No fix yet |
| sds npm | < 4.0.0
| 4.0.0
|
Description
Affected versions of sds are vulnerable to prototype pollution. The set function does not restrict the modification of an Object's prototype, which may allow an attacker to add or modify an existing property that will exist on all objects.
Recommendation
Upgrade to version 4.0.0 or later
NVD description
sds through 3.2.0 is vulnerable to Prototype Pollution.The library could be tricked into adding or modifying properties of the 'Object.prototype' by abusing the 'set' function located in 'js/set.js'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free