En bref
- CVE-2020-7942 est une vulnérabilité MOYENNE (CVSS 6.5) touchant puppet, puppet (puppet), puppet agent (puppet).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.80%, plus élevée que 56.6% des vulnérabilités.
- Correctif : mettre à jour vers 6.13.0, 5.5.19 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| puppet RubyGems | ≥ 6.0.0, < 6.13.0< 5.5.19
| 6.13.05.5.19
|
| puppet | ≥ 5.5.0, < 5.5.19≥ 6.0.0, < 6.13.0
| 5.5.196.13.0
|
| puppet agent | ≥ 5.5.0, < 5.5.19≥ 6.0.0, < 6.13.0
| 5.5.196.13.0
|
Description
Previously, Puppet operated on the model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure. When a node's catalog falls back to the default node, the catalog can be retrieved for a different node by modifying facts for the Puppet run. This issue can be mitigated by setting strict_hostname_checking = true in puppet.conf on your Puppet master. Puppet 6.13.0 changes the default behavior for strict_hostname_checking from false to true. It is recommended that Puppet Open Source and Puppet Enterprise users that are not upgrading still set strict_hostname_checking to true to ensure secure behavior.
NVD description
Previously, Puppet operated on a model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure. When a node's catalog falls back to the `default` node, the catalog can be retrieved for a different node by modifying facts for the Puppet run. This issue can be mitigated by setting `strict_hostname_checking = true` in `puppet.conf` on your Puppet master. Puppet 6.13.0 and 5.5.19 changes the default behavior for strict_hostname_checking from false to true. It is recommended that Puppet Open Source and Puppet Enterprise users that are not upgrading still set strict_hostname_checking to true to ensure secure behavior. Affected software versions: Puppet 6.x prior to 6.13.0 Puppet Agent 6.x prior to 6.13.0 Puppet 5.5.x prior to 5.5.19 Puppet Agent 5.5.x prior to 5.5.19 Resolved in: Puppet 6.13.0 Puppet Agent 6.13.0 Puppet 5.5.19 Puppet Agent 5.5.19
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free