En bref
- CVE-2021-21353 est une vulnérabilité CRITIQUE (CVSS 9.0) touchant pug (pugjs), pug-code-gen (pugjs), pug.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 4.3%, plus élevée que 91.1% des vulnérabilités.
- Correctif : mettre à jour vers 3.0.1, 3.0.2, 2.0.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pug | < 3.0.1
| 3.0.1
|
| pug-code-gen | ≥ 3.0.0, < 3.0.2< 2.0.3
| 3.0.22.0.3
|
| pug npm | < 3.0.1
| 3.0.1
|
| pug-code-gen npm | ≥ 3.0.0, < 3.0.2< 2.0.3
| 3.0.22.0.3
|
Description
Impact
If a remote attacker was able to control the pretty option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend.
Patches
Upgrade to [email protected] or [email protected] or [email protected], which correctly sanitise the parameter.
Workarounds
If there is no way for un-trusted input to be passed to pug as the pretty option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.
References
Original report: https://github.com/pugjs/pug/issues/3312
For more information
If you believe you have found other vulnerabilities, please DO NOT open an issue. Instead, you can follow the instructions in our Security Policy
NVD description
Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. This is fixed in version 3.0.1. This advisory applies to multiple pug packages including "pug", "pug-code-gen". pug-code-gen has a backported fix at version 2.0.3. This advisory is not exploitable if there is no way for un-trusted input to be passed to pug as the `pretty` option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free