En bref
- CVE-2021-24040 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant parlai, parlai (facebook).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 17.4%, plus élevée que 97.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.1.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parlai PyPI | < 1.1.0
| 1.1.0
|
| parlai | < 1.1.0
| 1.1.0
|
Description
Impact
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks.
Patches
The issue can be patched by upgrading to v1.1.0 or later. It can also be patched by replacing YAML deserialization with equivalent safe_load calls.
References
NVD description
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free