| Package | Affected versions | Patched versions |
|---|---|---|
| mautic/core | ≥ 4.0.0-alpha1, < 4.0.0< 3.3.4 | 4.0.03.3.4 |
| mautic | = 4.0.0< 3.3.4 | 3.3.4 |
Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack through the contact's first or last name and triggered when viewing a contact's details page then clicking on the action drop down and hovering over the Campaigns button. Contact first and last name can be populated from different sources such as UI, API, 3rd party syncing, forms, etc.
Upgrade to 3.3.4 or 4.0.0
No
https://github.com/mautic/mautic/releases/tag/3.3.4 https://github.com/mautic/mautic/releases/tag/4.0.0
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free