En bref
- CVE-2021-29469 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant redis (redis.js), redis.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 76.3% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| redis | < 3.1.1
| 3.1.1
|
| redis npm | ≥ 2.6.0, < 3.1.1
| 3.1.1
|
Description
Impact
When a client is in monitoring mode, the regex begin used to detected monitor messages could cause exponential backtracking on some strings. This issue could lead to a denial of service.
Patches
The problem was fixed in commit 2d11b6d and was released in version 3.1.1.
References
#1569 (GHSL-2021-026)
NVD description
Node-redis is a Node.js Redis client. Before version 3.1.1, when a client is in monitoring mode, the regex begin used to detected monitor messages could cause exponential backtracking on some strings. This issue could lead to a denial of service. The issue is patched in version 3.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free