En bref
- CVE-2021-29621 est une vulnérabilité MOYENNE (CVSS 5.3) touchant flask-appbuilder, airflow (apache), flask-appbuilder (dpgaspar).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.4%, plus élevée que 88.9% des vulnérabilités.
- Correctif : mettre à jour vers 3.3.0 ou plus récent.
Description
Impact
User enumeration in database authentication in Flask-AppBuilder <= 3.2.3. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in.
Patches
Upgrade to 3.3.0
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is a development framework, built on top of Flask. User enumeration in database authentication in Flask-AppBuilder <= 3.2.3. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Upgrade to version 3.3.0 or higher to resolve.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free