En bref
- CVE-2021-32649 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant october/system, october (octobercms).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 71.2% des vulnérabilités.
- Correctif : mettre à jour vers 1.1.6, 1.0.473 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 1.1.0, < 1.1.6< 1.0.473
| 1.1.61.0.473
|
| october | ≥ 1.1.0, < 1.1.6< 1.0.473
| 1.1.61.0.473
|
Description
Impact
Assuming an attacker with "create, modify and delete website pages" privileges in the backend is able to execute PHP code by running specially crafted Twig code in the template markup.
Patches
Issue has been patched in Build 473 and v1.1.6
Workarounds
Apply https://github.com/octobercms/october/commit/167b592eed291ae1563c8fcc5b9b34a03a300f26 to your installation manually if you are unable to upgrade.
References
Credits to:
• David Miller
For more information
If you have any questions or comments about this advisory:
NVD description
October CMS is a self-hosted content management system (CMS) platform based on the Laravel PHP Framework. Prior to versions 1.0.473 and 1.1.6, an attacker with "create, modify and delete website pages" privileges in the backend is able to execute PHP code by running specially crafted Twig code in the template markup. The issue has been patched in Build 473 (v1.0.473) and v1.1.6. Those unable to upgrade may apply the patch to their installation manually as a workaround.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free