En bref
- CVE-2021-32661 est une vulnérabilité ÉLEVÉE (CVSS 7.3) touchant @backstage/plugin-techdocs (linuxfoundation), @backstage/plugin-techdocs.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.2%, plus élevée que 68.5% des vulnérabilités.
- Correctif : mettre à jour vers 0.9.5 ou plus récent.
Description
Impact
A malicious internal actor can potentially upload documentation content with malicious scripts by embedding the script within an object element. This may give access to sensitive data when other users visit that same documentation page.
The ability to upload malicious content may be limited by internal code review processes, unless the chosen TechDocs deployment method is to use an object store and the actor has access to upload files directly to that store.
Patches
The vulnerability is patched in the 0.9.5 release of @backstage/plugin-techdocs.
For more information
If you have any questions or comments about this advisory:
NVD description
Backstage is an open platform for building developer portals. In versions of Backstage's Techdocs Plugin (`@backstage/plugin-techdocs`) prior to 0.9.5, a malicious internal actor can potentially upload documentation content with malicious scripts by embedding the script within an `object` element. This may give access to sensitive data when other users visit that same documentation page. The ability to upload malicious content may be limited by internal code review processes, unless the chosen TechDocs deployment method is to use an object store and the actor has access to upload files directly to that store. The vulnerability is patched in the `0.9.5` release of `@backstage/plugin-techdocs`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free