En bref
- CVE-2021-32669 est une vulnérabilité MOYENNE (CVSS 5.4) touchant typo3/cms, typo3/cms-core, typo3 (typo3).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.60%, plus élevée que 48.8% des vulnérabilités.
- Correctif : mettre à jour vers 10.4.18, 11.3.1, 9.5.28, 8.7.41 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| typo3/cms Packagist | ≥ 10.0.0, < 10.4.18≥ 11.0.0, < 11.3.1≥ 9.0.0, < 9.5.28
| 10.4.1811.3.19.5.28
|
| typo3/cms-core Packagist | ≥ 10.0.0, < 10.4.18≥ 11.0.0, < 11.3.1≥ 8.0.0, < 8.7.41≥ 9.0.0, < 9.5.28
| 10.4.1811.3.18.7.419.5.28
|
| typo3 | ≥ 10.0.0, ≤ 10.4.17≥ 11.0.0, ≤ 11.3.0≥ 8.0.0, ≤ 8.7.40≥ 9.0.0, ≤ 9.5.28
| No fix yet |
Description
Problem
Failing to properly encode settings for backend layouts, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability.
Solution
Update to TYPO3 versions 8.7.41 ELTS, 9.5.28, 10.4.18, 11.3.1 that fix the problem described.
Credits
Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.
NVD description
TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When settings for _backend layouts_ are not properly encoded, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free