En bref
- CVE-2021-32699 est une vulnérabilité MOYENNE (CVSS 6.5) touchant github.com/pterodactyl/wings, wings (pterodactyl).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.27%, plus élevée que 18.5% des vulnérabilités.
- Correctif : mettre à jour vers 1.4.4 ou plus récent.
Description
Impact
All versions of Pterodactyl Wings preior to 1.4.4 are vulnerable to system resource exhaustion due to improper container process limits being defined. A malicious user can consume more resources than intended and cause downstream impacts to other clients on the same hardware, eventually causing the physical server to stop responding.
Patches
Users should upgrade to 1.4.4.
Workarounds
There is no non-code based workaround for impacted versions of the software. Users running customized versions of this software can manually set a PID limit for containers created.
For more information
If you have any questions or comments about this advisory:
- Contact us on Discord
- Email us at
dane ät pterodactyl dot io
NVD description
Wings is the control plane software for the open source Pterodactyl game management system. All versions of Pterodactyl Wings prior to `1.4.4` are vulnerable to system resource exhaustion due to improper container process limits being defined. A malicious user can consume more resources than intended and cause downstream impacts to other clients on the same hardware, eventually causing the physical server to stop responding. Users should upgrade to `1.4.4` to mitigate the issue. There is no non-code based workaround for impacted versions of the software. Users running customized versions of this software can manually set a PID limit for containers created.
Autres vulnérabilités de github.com/pterodactyl/wings
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free