En bref
- CVE-2021-3377 est une vulnérabilité MOYENNE (CVSS 6.1) touchant ansi up (ansi up project), ansi_up.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 8.0%, plus élevée que 94.8% des vulnérabilités.
- Correctif : mettre à jour vers 5.0.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| ansi up | < 5.0.0
| 5.0.0
|
| ansi_up npm | < 5.0.0
| 5.0.0
|
Description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
NVD description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free