En bref
- CVE-2021-39171 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant passport-saml (passport-saml project), passport-saml.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 71.0% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.0 ou plus récent.
Description
Impact
A malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack.
Patches
This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
References
https://github.com/node-saml/passport-saml/pull/595
NVD description
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free